Ciscoルータ1812JでPPPoEを設定する方法

Author Image

Text By:techhub Blog 編集部

techhub-blog-1091-cisco-thumbnail

Ciscoルータの1812Jを使用した、社内LAN環境を構築しました。Ciscoルータをブロードバンドルータとして使っていて、その時のおこなったPPPoE設定についてご紹介いたします。

PPPoEについて
標準的な通信プロトコル(通信手順)の一つで、常時接続の通信回線やネットワーク上で、二台の機器の間で仮想的な専用の伝送路を確立し、相互に安定的にデータの送受信を行うことができるようにするもの。家庭などからxDSL(ADSLなど)や光ファイバー(FTTH)、CATVなどの常時接続のインターネット接続サービスを利用する際によく利用される。

出典:IT用語辞典 e-Words

PPPoEを設定するためのコンフィグ

IOS(CiscoのOSです)12.4の以前・以降によって、設定の内容は異なります。

今回は12.4以降の設定内容となります。

[xhtml]
interface Fastethernet0
no ip address
pppoe enable
pppoe-client dial-pool-number 1
no shutdown

interface dialer 1
ip address negotiated
ip mtu 1454
dialer pool 1
dialer-group 1
encapsulation ppp
ppp authentication chap callin
ppp chap hostname XXXX@XXXX
ppp chap password XXXX
ip nat outside
ip tcp adjust-mss 1414

interface Vlan1
ip address XX.XX.XX.XX XX.XX.XX.XX
ip nat inside

access-list 1 permit XX.XX.XX.XX XX.XX.XX.XX
ip nat pool nat-pool XX.XX.XX.XX XX.XX.XX.XX netmask XX.XX.XX.XXX
ip nat inside source list 1 pool nat-pool overload
dialer-list 1 protocol ip permit

ip route 0.0.0.0 0.0.0.0 dialer1
[/xhtml]

使用したコンフィグについて

No コンフィグ 説明
1 pppoe enable インターフェースでPPPoEを有効にする
2 pppoe-client dial-pool-number 1 dialer pool 1に所属するインターフェースはPPPoEを使って接続する
3 interface dialer 1 dialerインターフェースを作成する
4 ip address negotiated プロバイダからグローバルIPアドレスを自動取得する
5 ip mtu 1454 MTU値を設定する
6 dialer pool 1 dialer poolを作成する
7 dialer group 1 dialer-listで定義するためにdialer groupを作成する
8 encapsulation ppp カプセル化方式をpppにする
9 ppp authentication chap callin 認証方法にchapを設定する
10 ppp chap hostname XXXX@XXXX 認証で使うためのユーザIDを設定する
11 ip tcp adjust-mss 1414 コネクション中に送信できるTCPデータの最大サイズを設定する
12 dialer-list 1 protocol ip permit PPPoE通信の開始パケットを設定する

検証するためのコマンド

No コマンド 説明
1 show interface dialer 1 WAN側のIPアドレスが表示されているか
2 show pppoe session RemMACにMACアドレスが表示されているか
3 show ppp all Peer AddressにIPアドレスが表示されているか
4 show ip int brief dialer、vlan インターフェースにIPアドレスが表示されているか

 

いかがでしたでしょうか。ネットワークエンジニアを目指す方は、ぜひ参考にしてみてください。

techhub Learning テックハブ・ラーニング 動画eラーニングで教育環境の充実化充実化!! 教育コストを削減 会社でも自宅でも学習 ITインフラに特化した教材 デモ環境の無料申し込み